Temporary Issues with Withdraws

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Feb 09, 2026 - 14:36 UTC

Investigating

We would like to inform you that the BCH network(s) will undergo maintenance for system updates. To ensure the security of operations, we have temporarily paused transactions. Thank you for your understanding.
Posted Feb 07, 2026 - 01:24 UTC