Intermittent delays with transactions

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 23:16 UTC

Investigating

Our systems are busy and some outgoing transactions may take a long time and experience instability. We are actively working to solve the issue.
Posted Feb 23, 2026 - 21:11 UTC