Instability at ETH outgoing transaction

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 20:28 UTC

Investigating

The network is busy and some outgoing transactions may take a long time and experience instability.
Posted Mar 02, 2026 - 15:31 UTC