SUI Network Deposits Temporarily Paused

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 17:07 UTC

Investigating

The SUI network is currently experiencing issues. Deposits are temporarily paused while the network recovers.
Any funds already sent are safe and will be credited to your account automatically once deposit functionality is restored.
Posted May 28, 2026 - 19:48 UTC
This incident affected: Blockchain Networks (Sui).