Ethereum network: delayed transaction confirmations

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 21:53 UTC

Identified

The Ethereum network is experiencing an issue causing delays in confirming transactions. Withdrawals may take longer than usual.  We are actively monitoring.
Posted Sep 11, 2026 - 15:11 UTC
This incident affected: Blockchain Networks (Ethereum).