AVAX Network Update
Incident Report for Foxbit
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 13:12 UTC
Investigating
Dear customers,

We would like to inform you that the AVAX network will undergo maintenance for system updates. To ensure the security of operations, we have temporarily paused transactions.

Thank you for your understanding.
Posted Mar 05, 2024 - 20:58 UTC
This incident affected: Blockchain Networks (Avalanche).