Intermittent delays with transactions

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 02:06 UTC

Investigating

The network is busy and some outgoing transactions may take a long time and experience instability.
Posted Feb 12, 2026 - 17:56 UTC
This incident affected: Blockchain Networks (Binance Smart Chain, Bitcoin, Ethereum, Litecoin, Polygon).