Blockchains CELESTIA Half

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 12:50 UTC

Investigating

Due to an unexpected issue with CELESTIA, these blockchains are currently unavailable. We are working to resolve the issue as quickly as possible. We will resume operations as soon as the issue is resolved.

Thank you for your understanding.
Posted Nov 24, 2025 - 17:39 UTC
This incident affected: Blockchain Networks (Celestia).