Blockchain Mantra is halted

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 13:25 UTC

Monitoring

The network is busy and some outgoing transactions may take a long time and experience instability.
Posted Aug 21, 2026 - 10:47 UTC
This incident affected: Blockchain Networks (Mantra).