Instability at ETH outgoing transaction

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 17:34 UTC

Identified

We are continuing to investigate this issue.
Posted Oct 24, 2025 - 14:52 UTC

Update

We are continuing to investigate this issue.
Posted Oct 24, 2025 - 14:51 UTC

Investigating

The network is busy and some outgoing transactions may take a long time and experience instability.
Posted Oct 24, 2025 - 13:53 UTC
This incident affected: Blockchain Networks (Ethereum).