Resolved
This incident has been resolved.
Posted Sep 14, 2026 - 17:05 UTC
Monitoring
Some crypto withdrawals and deposits are currently taking longer than usual to be processed. Requests are being received and queued normally, and will be completed as processing returns to normal.
Our team is monitoring the situation.
Posted Sep 12, 2026 - 20:24 UTC
This incident affected: Blockchain Networks (Algo, Arbitrum, Avalanche, Binance Smart Chain, Bitcoin, Bitcoin Cash, Cardano, Celestia, Cosmos, Dogecoin, EOS, Ethereum, Hathor, Litecoin, Near, Optimism, Polkadot, Polygon, Sei, Solana, Stellar, Tezos, Tron, Ripple, Hedera, Ronin, INJ, Ton, Sui, Mantra).