Issues with outgoing transactions

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 14:18 UTC

Investigating

The networks is busy and some outgoing transactions may take a long time and experience instability.
Posted Jul 07, 2026 - 14:02 UTC
This incident affected: Blockchain Networks (Bitcoin, Litecoin).