Issues with outgoing transactions

Incident Report for Foxbit

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 19:39 UTC

Investigating

The network is busy and some outgoing transactions may take a long time and experience instability.
Posted Mar 23, 2026 - 17:07 UTC